Google Ads Temporarily Unavailable
Incident Report for AdClicks
Resolved
Google ads is back working, the incident has been resolved
Posted Mar 07, 2023 - 14:18 CST
Update
We are continuing to investigate this issue.
Posted Mar 07, 2023 - 09:44 CST
Investigating
Our team is currently reviewing our Google Ads integration and we'll keep you posted as soon as we know more.

In the meantime, we appreciate your patience,
Posted Mar 07, 2023 - 09:43 CST
This incident affected: Reporting API and Core API.