Delays With Facebook Ads
Incident Report for AdClicks
Resolved
This incident has been resolved.

Adclicks launched a native Facebook connector which will allow users to re-authenticate their credentials and have a seamless user experience.
Posted Oct 06, 2023 - 14:18 CST
Identified
We are experiencing some delays with our Facebook provider, Supermetrics which may cause some slowness when loading the data.

We apologize for the delay and any inconvenience that this may cause you.
Posted Sep 05, 2023 - 16:20 CST
This incident affected: Reporting API, Core API, and Main Application UI.