Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 08, 2025 - 16:30 CST
Scheduled
We will be deploying our May 2025 release this afternoon. During this time, the system may be temporarily unavailable.
This release introduces a beta version of the SEO Keyword Tracker, allowing you to monitor keyword performance directly in your reports. We’ve also made several usability improvements, including clearer labels and tooltips in the Scorecard widget and standardized date formats across all reports. In addition, we resolved key bugs that were affecting data sorting and Facebook filters. Behind the scenes, we’ve upgraded our systems to the latest version of Meta’s API and Angular v18 to ensure continued performance and stability.
We recommend avoiding critical tasks during this window. Thank you for your patience and continued support!
Posted May 08, 2025 - 12:14 CST
This scheduled maintenance affected: Reporting API, Core API, Main Application UI, and Security API.